Does using jQuery Migrate in production make your program less secure than sticking with an outdated version of jQuery?

  javascript, jquery

Re-worded question to make it more focused and reposted as directed.

I need to update jQuery because of security risks affecting jQuery 2 which is what my project currently uses. Our project relies heavily on a certain JavaScript library that is not compatible with anything later than jQuery 2. It is not an option to update that certain library.

In the interest of making the program more secure, is it better to update the code and rely on jQuery Migrate to give back some lost functionalities, or to just not update jQuery at all and stick with jQuery 2.0?

Source: Ask Javascript Questions

LEAVE A COMMENT